Skip to content

Export page to PDF
Adobe Flash Player Object Confusion Vulnerability (CVE-2012-0779)
CVE ID
CVE-2012-0779
Severity
Critical

Description

This update addresses an object confusion vulnerability in the 11.2.202.233 and earlier versions of Adobe Flash Player for Windows, Macintosh and Linux, Adobe Flash Player 11.1.115.7 and earlier for Android 4.x, and Adobe Flash Player 11.1.111.8 and earlier versions for Android 3.x and 2.x. This vulnerability could cause the application to crash and potentially allow an attacker to take control of the affected system.

Solution

Trend Micro Deep Security shields the following vulnerabilities using the specified rules. Trend Micro customers using OfficeScan with the Intrusion Defense Firewall plugin are also protected from attacks using these vulnerabilities.



Adobe Bulletin ID Vulnerability ID Rule Number & Title Deep Security Pattern Version Deep Security Pattern Release Date
APSB12-012 CVE-2012-0779 1005000- Adobe Flash Player Object Confusion Vulnerability (CVE-2012-0779) 12-012 May 8, 2012
APSB12-013 CVE-2012-0779 1005019- Restrict Microsoft Office File With Linked SWF 12-012 May 8, 2012
Patch: http://www.adobe.com/support/security/bulletins/apsb12-09.html
Affected software and version:

Adobe Flash Player 11.2.202.233 and earlier versions for Windows
Macintosh and Linux operating systems
Adobe Flash Player 11.1.115.7 and earlier versions for Android 4.x
Adobe Flash Player 11.1.111.8 and earlier versions for Android 3.x and 2.x


Connect with us on